Equipment & Software

Blackboard Browser Requirements Check

Important: At a minimum, Blackboard requires JavaScript and Cookies to be enabled in your browser. For more information regarding Blackboard browser requirements, please refer to the Browser Settings Guide.

If you pass all checks listed below, you should be able to use the main features of Blackboard.

 
BrowserCheck Warning
Browser:
Version:
Platform:
For a list of supported Browsers, please refer to the Browser Support Matrix.
 
JavaScriptCheck Fail If this check fails, refer to the Browser Settings Guide for instructions on enabling Javascript for your browser.
 
CookiesCheck Fail If this check fails, refer to the Browser Settings Guide for instructions on enabling Cookies for your browser.
 
PopupWindowCheck Fail If this check fails, refer to the Browser Settings Guide for instructions on enabling Popup Windows for your browser.
 
Port 80Check Fail This check works by trying to download an image through the specified port. Port 80 is the standard web (http) port.
 
JavaCheck Java: Version(s):

The version of Java that Blackboard currently supports is 1.7.0_x. Older versions may work, but if you're experiencing problems with Blackboard, you may try updating your Java Plug-in.

If more than one version is listed, we recommended you remove the older version(s) to eliminate potential security vulnerabilities, Java Unistall Tool.

 
Plugin Checks
Plugin Installed Version
Adobe Flash
Adobe Shockwave
Adobe Reader
Apple QuickTime
RealPlayer
Windows Media Player